Degraded performance on the app
Incident Report for Pento
Resolved
We found the issue and resolved it. Apologies for any inconveniences.
Posted Sep 14, 2021 - 09:02 UTC
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Sep 14, 2021 - 08:48 UTC
This incident affected: App.