Website unresponsive
Incident Report for Pento
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 07:17 UTC
Investigating
https://www.pento.io is experiencing down time in parts of the world. We're investigating the issue.
Posted Jun 21, 2022 - 06:36 UTC
This incident affected: Website.