Website unresponsive
Incident Report for Pento
Resolved
This incident has been resolved.
Posted Feb 09, 2022 - 12:16 UTC
Investigating
https://www.pento.io is experiencing down time in parts of the world. We're investigating the issue.
Posted Feb 09, 2022 - 12:09 UTC
This incident affected: Website.