Issues with Departments
Incident Report for Pento
Resolved
This incident has been resolved.
Posted Aug 02, 2022 - 19:39 UTC
Monitoring
we are monitoring the system for irregularities
Posted Aug 02, 2022 - 14:33 UTC
Investigating
We are currently experiencing a fault with department functionality and are working to resolve the issue
Posted Aug 02, 2022 - 11:49 UTC
This incident affected: App.