Website unresponsive
Incident Report for Pento
Resolved
This incident has been resolved.
Posted Sep 30, 2021 - 14:13 UTC
Investigating
https://www.pento.io is experiencing down time in parts of the world. We're investigating the issue.
Posted Sep 30, 2021 - 14:11 UTC
This incident affected: Website.