Some users are experiencing problems downloading reports
Incident Report for Pento
Resolved
The incident is now resolved.
Posted Jan 25, 2022 - 13:52 UTC
Identified
We have found the root cause of the issue and are deploying a fix.
Posted Jan 25, 2022 - 11:37 UTC
Investigating
We have reports of users having trouble downloading reports.
We are investigating the issue and will report back as soon as possible.
Posted Jan 25, 2022 - 10:55 UTC
This incident affected: App.