Website unresponsive
Incident Report for Pento
Resolved
This incident has been resolved.
Posted Dec 21, 2021 - 21:27 UTC
Investigating
https://www.pento.io is experiencing down time in parts of the world. We're investigating the issue.
Posted Dec 21, 2021 - 21:18 UTC
This incident affected: Website.