Payroll page failing to load
Resolved·Degraded performance

We think the impact from the issue is over.

Wed, Feb 16, 2022, 12:38 PM
(3 years ago)
·
Affected components
App
Updates

Resolved

We think the impact from the issue is over.

Wed, Feb 16, 2022, 12:38 PM

Monitoring

We have confirmed that payrolls are loading and the issue has been resolved

Wed, Feb 16, 2022, 12:35 PM

Monitoring

We have deployed a fix and are monitoring if the issue persists

Wed, Feb 16, 2022, 12:28 PM

Investigating

We've identified why the issue with payrolls loading is happening, and we're in the process of fixing it.

Wed, Feb 16, 2022, 11:57 AM(30 minutes earlier)

Investigating

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.

Wed, Feb 16, 2022, 11:29 AM(28 minutes earlier)