Degraded performance on the app
Incident Report for Pento
Resolved
We found the cause and removed it.
Posted Sep 10, 2021 - 08:57 UTC
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Sep 10, 2021 - 08:45 UTC
This incident affected: App.