Issues with Departments
Resolved
Partial outage

This incident has been resolved.

Tue, Aug 2, 2022, 07:39 PM
2 years ago
Affected components
App
Updates

Resolved

This incident has been resolved.

Tue, Aug 2, 2022, 07:39 PM
5h earlier...

Monitoring

we are monitoring the system for irregularities

Tue, Aug 2, 2022, 02:33 PM
2h earlier...

Investigating

We are currently experiencing a fault with department functionality and are working to resolve the issue

Tue, Aug 2, 2022, 11:49 AM